Back to overview
Power is out
May 25, 2024 at 12:21am UTC
Affected services
Plex
xanxic.com
Resolved
May 25, 2024 at 12:21am UTC
6:13pm-10:02pm
House has no power, yay Duke!
Affected services
Resolved
May 25, 2024 at 12:21am UTC
6:13pm-10:02pm
House has no power, yay Duke!
Affected services