Back to overview
Downtime
Power outage
Jul 16, 2024 at 04:18pm UTC
Affected services
Plex
xanxic.com
Resolved
Jul 16, 2024 at 10:04pm UTC
Yay Power
Affected services
Created
Jul 16, 2024 at 04:18pm UTC
Power is out across town for 2k customers. I seem to be apart of that. Yay
Affected services